#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=5\*14)[\s\S]*?(\d{5}\.\d{2})"
Local $sString = "120.65UAH Produkti Kvartal" & @CRLF & _
"5*34 14:24" & @CRLF & _
"Bal. 16603.52UAH" & @CRLF & _
"" & @CRLF & _
"120.65UAH Produkti Kvartal" & @CRLF & _
"5*14 14:24" & @CRLF & _
"Bal. 16603.52UAH" & @CRLF & _
"" & @CRLF & _
"120.65UAH Produkti Kvartal" & @CRLF & _
"5*14 14:24" & @CRLF & _
"Bal. 11111.52UAH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")