import Foundation
let pattern = #"(?=5\*14)[\s\S]*?(\d{5}\.\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
120.65UAH Produkti Kvartal
5*34 14:24
Bal. 16603.52UAH
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 11111.52UAH
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)