using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=5\*14)[\s\S]*?(\d{5}\.\d{2})";
string input = @"120.65UAH Produkti Kvartal
5*34 14:24
Bal. 16603.52UAH
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 11111.52UAH";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}