$re = '/(?=5\*14)[\s\S]*?(\d{5}\.\d{2})/';
$str = '120.65UAH Produkti Kvartal
5*34 14:24
Bal. 16603.52UAH
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 11111.52UAH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);