import re
regex = re.compile(r"(?=5\*14)[\s\S]*?(\d{5}\.\d{2})")
test_str = ("120.65UAH Produkti Kvartal\n"
"5*34 14:24\n"
"Bal. 16603.52UAH\n\n"
"120.65UAH Produkti Kvartal\n"
"5*14 14:24\n"
"Bal. 16603.52UAH\n\n"
"120.65UAH Produkti Kvartal\n"
"5*14 14:24\n"
"Bal. 11111.52UAH")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")