const regex = /(?=5\*14)[\s\S]*?(\d{5}\.\d{2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=5\\*14)[\\s\\S]*?(\\d{5}\\.\\d{2})', 'g')
const str = `120.65UAH Produkti Kvartal
5*34 14:24
Bal. 16603.52UAH
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 11111.52UAH`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}