#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ABC[0-9]{5}$"
Local $sString = "ABC72961" & @CRLF & _
"ABC2345" & @CRLF & _
"AB12345" & @CRLF & _
"ABABABAB" & @CRLF & _
"ABC00000" & @CRLF & _
"ABC12345" & @CRLF & _
"ABC123456" & @CRLF & _
"LOLABC12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")