$re = '/^ABC[0-9]{5}$/m';
$str = 'ABC72961
ABC2345
AB12345
ABABABAB
ABC00000
ABC12345
ABC123456
LOLABC12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);