// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ABC[0-9]{5}$").unwrap();
let string = "ABC72961
ABC2345
AB12345
ABABABAB
ABC00000
ABC12345
ABC123456
LOLABC12345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}