using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ABC[0-9]{5}$";
string input = @"ABC72961
ABC2345
AB12345
ABABABAB
ABC00000
ABC12345
ABC123456
LOLABC12345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}