re = /^ABC[0-9]{5}$/m
str = 'ABC72961
ABC2345
AB12345
ABABABAB
ABC00000
ABC12345
ABC123456
LOLABC12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end