import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ABC[0-9]{5}$";
final String string = "ABC72961\n"
+ "ABC2345\n"
+ "AB12345\n"
+ "ABABABAB\n"
+ "ABC00000\n"
+ "ABC12345\n"
+ "ABC123456\n"
+ "LOLABC12345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}