import re
regex = re.compile(r"^ABC[0-9]{5}$", flags=re.MULTILINE)
test_str = ("ABC72961\n"
"ABC2345\n"
"AB12345\n"
"ABABABAB\n"
"ABC00000\n"
"ABC12345\n"
"ABC123456\n"
"LOLABC12345")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")