# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([[:alpha:]]+)-[0-9].*\.*rpm/$1/gm;t' <<< "xorg-x11-font-utils-7.5-21.el7.x86_64.rpm"