const regex = /([[:alpha:]]+)-[0-9].*\.*rpm/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([[:alpha:]]+)-[0-9].*\\.*rpm', 'gm')
const str = `xorg-x11-font-utils-7.5-21.el7.x86_64.rpm`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);