// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([[:alpha:]]+)-[0-9].*\.*rpm").unwrap();
let string = "xorg-x11-font-utils-7.5-21.el7.x86_64.rpm";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}