using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([[:alpha:]]+)-[0-9].*\.*rpm";
string substitution = @"$1";
string input = @"xorg-x11-font-utils-7.5-21.el7.x86_64.rpm";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}