package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([[:alpha:]]+)-[0-9].*\.*rpm`)
var str = `xorg-x11-font-utils-7.5-21.el7.x86_64.rpm`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}