$re = '/([[:alpha:]]+)-[0-9].*\.*rpm/m';
$str = 'xorg-x11-font-utils-7.5-21.el7.x86_64.rpm';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;