# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?:\d{1,3}\.){3}\d{1,3}\s*){2}([a-z]+)/\1/g;t' <<< "192.10.678.234 192.12.898.123 public
192.10.567.6 3.3.3.3 public
192.20.123.39 123.34.31.678 private"