import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:\\d{1,3}\\.){3}\\d{1,3}\\s*){2}([a-z]+)";
final String string = "192.10.678.234 192.12.898.123 public\n"
+ "192.10.567.6 3.3.3.3 public\n"
+ "192.20.123.39 123.34.31.678 private";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}