package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:\d{1,3}\.){3}\d{1,3}\s*){2}([a-z]+)`)
var str = `192.10.678.234 192.12.898.123 public
192.10.567.6 3.3.3.3 public
192.20.123.39 123.34.31.678 private`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}