const regex = /(?:(?:\d{1,3}\.){3}\d{1,3}\s*){2}([a-z]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:\\d{1,3}\\.){3}\\d{1,3}\\s*){2}([a-z]+)', 'g')
const str = `192.10.678.234 192.12.898.123 public
192.10.567.6 3.3.3.3 public
192.20.123.39 123.34.31.678 private`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);