use strict;
my $str = '192.10.678.234 192.12.898.123 public
192.10.567.6 3.3.3.3 public
192.20.123.39 123.34.31.678 private';
my $regex = qr/(?:(?:\d{1,3}\.){3}\d{1,3}\s*){2}([a-z]+)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";