using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:\d{1,3}\.){3}\d{1,3}\s*){2}([a-z]+)";
string substitution = @"\1";
string input = @"192.10.678.234 192.12.898.123 public
192.10.567.6 3.3.3.3 public
192.20.123.39 123.34.31.678 private";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}