# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:\d{1,3}\.){3}\d{1,3}\s*){2}([a-z]+)"
test_str = ("192.10.678.234 192.12.898.123 public\n"
"192.10.567.6 3.3.3.3 public\n"
"192.20.123.39 123.34.31.678 private")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.