# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/From.*//g;t' <<< "Vans model 10 . 390 From Random Data
Nike model 982 . Errant From Default Data
Timberland old school From Whatever"