import Foundation
let pattern = #"From.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Vans model 10 . 390 From Random Data
Nike model 982 . Errant From Default Data
Timberland old school From Whatever
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)