import re
regex = re.compile(r"From.*")
test_str = ("Vans model 10 . 390 From Random Data\n"
"Nike model 982 . Errant From Default Data\n"
"Timberland old school From Whatever")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)