using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"From.*";
string substitution = @"";
string input = @"Vans model 10 . 390 From Random Data
Nike model 982 . Errant From Default Data
Timberland old school From Whatever";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}