#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "From.*"
Local $sString = "Vans model 10 . 390 From Random Data" & @CRLF & _
"Nike model 982 . Errant From Default Data" & @CRLF & _
"Timberland old school From Whatever"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)