$re = '/From.*/';
$str = 'Vans model 10 . 390 From Random Data
Nike model 982 . Errant From Default Data
Timberland old school From Whatever';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;