# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*a)(?=.*b)[abc]*$//gmix;t' <<< "dabc
fbca
cab
bac
acb
cba
"