$re = '/^(?=.*a)(?=.*b)[abc]*$/mix';
$str = 'dabc
fbca
cab
bac
acb
cba
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;