const regex = /^(?=.*a)(?=.*b)[abc]*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*a)(?=.*b)[abc]*$', 'gmi')
const str = `dabc
fbca
cab
bac
acb
cba
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);