use strict;
my $str = 'dabc
fbca
cab
bac
acb
cba
';
my $regex = qr/^(?=.*a)(?=.*b)[abc]*$/mixp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";