re = /^(?=.*a)(?=.*b)[abc]*$/mix
str = 'dabc
fbca
cab
bac
acb
cba
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result