import re
regex = re.compile(r"""
^(?=.*a)(?=.*b)[abc]*$
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("dabc\n"
"fbca\n"
"cab\n"
"bac\n"
"acb\n"
"cba\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)