# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)[[:blank:]]+(?!$)|[[:blank:]]+(?=\d)/|/gm;t' <<< "708 447 4797 JOHN SMITH 18000
708 447 4797 JOHN SMITH 18000
708 447 4797 JOHN SMITH 18000
708 -3.00 4797 JOHN SMITH 18000"