re = /(?<=\d)[[:blank:]]+(?!$)|[[:blank:]]+(?=\d)/m
str = '708 447 4797 JOHN SMITH 18000
708 447 4797 JOHN SMITH 18000
708 447 4797 JOHN SMITH 18000
708 -3.00 4797 JOHN SMITH 18000'
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result