import Foundation
let pattern = #"(?<=\d)[[:blank:]]+(?!$)|[[:blank:]]+(?=\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
708 447 4797 JOHN SMITH 18000
708 447 4797 JOHN SMITH 18000
708 447 4797 JOHN SMITH 18000
708 -3.00 4797 JOHN SMITH 18000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)