use strict;
my $str = '708 447 4797 JOHN SMITH 18000
708 447 4797 JOHN SMITH 18000
708 447 4797 JOHN SMITH 18000
708 -3.00 4797 JOHN SMITH 18000';
my $regex = qr/(?<=\d)[[:blank:]]+(?!$)|[[:blank:]]+(?=\d)/mp;
my $subst = '|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";