#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\d)[[:blank:]]+(?!$)|[[:blank:]]+(?=\d)"
Local $sString = "708 447 4797 JOHN SMITH 18000" & @CRLF & _
"708 447 4797 JOHN SMITH 18000" & @CRLF & _
"708 447 4797 JOHN SMITH 18000" & @CRLF & _
"708 -3.00 4797 JOHN SMITH 18000"
Local $sSubst = "|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)