import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d)[[:blank:]]+(?!$)|[[:blank:]]+(?=\\d)";
final String string = "708 447 4797 JOHN SMITH 18000\n"
+ "708 447 4797 JOHN SMITH 18000\n"
+ "708 447 4797 JOHN SMITH 18000\n"
+ "708 -3.00 4797 JOHN SMITH 18000";
final String subst = "|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}