import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)<img[^>]*>(*SKIP)(*F)|\\bNavigation\\b";
final String string = "Navigation\n"
+ "<img src=\"Navigation.jpg\" />\n"
+ "Navigation\n"
+ "<img src=\"Navigation.jpg\" />\n"
+ "<b>Navigation</b>\n"
+ "<img src=\"Navigation\" />\n"
+ "Navigation\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}