$re = '~(?i)<img[^>]*>(*SKIP)(*F)|\bNavigation\b~';
$str = 'Navigation
<img src="Navigation.jpg" />
Navigation
<img src="Navigation.jpg" />
<b>Navigation</b>
<img src="Navigation" />
Navigation
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);