// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<img[^>]*>(*SKIP)(*F)|\bNavigation\b").unwrap();
let string = "Navigation
<img src=\"Navigation.jpg\" />
Navigation
<img src=\"Navigation.jpg\" />
<b>Navigation</b>
<img src=\"Navigation\" />
Navigation
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}