const regex = new RegExp('(?i)<img[^>]*>(*SKIP)(*F)|\\bNavigation\\b', 'g')
const str = `Navigation
<img src="Navigation.jpg" />
Navigation
<img src="Navigation.jpg" />
<b>Navigation</b>
<img src="Navigation" />
Navigation
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}