import re
regex = re.compile(r"(?i)<img[^>]*>(*SKIP)(*F)|\bNavigation\b")
test_str = ("Navigation\n"
"<img src=\"Navigation.jpg\" />\n"
"Navigation\n"
"<img src=\"Navigation.jpg\" />\n"
"<b>Navigation</b>\n"
"<img src=\"Navigation\" />\n"
"Navigation\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")