# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\[[0-9]*]:)(.*)\r?\n?//gm;t' <<< "this is a [link][1]
[1]: http://example.com
and this is a [good website][2] in my opinion
[2]: http://goodwebsite.com
[3]: http://example.com/fsadf.jpg
[![this is a photo][3]][3]
and there is some text hare ..!"